import re
regex = re.compile(r".")
test_str = ("Lorem ipsúm dolor sit amet, sóleat coñsetetur et nam, vocibus convenire an vis. ¿Nostrum mediócritatem hís cu? Lobortis vítuperata has ñe. ¡Vis ex mágna summo coñsequat, mándamus mediocrem repudiare ut méa, ne eám sempér melius! ¿Ullúm debitis ut duo? Cu vídit sigñiferúmque vel, quo ex simul facilís, mea ridens maiorum ad.\n\n"
"Unum vero at his. Numquam habemús medíocrem pri et, pró erroribús incorrupte ad, debet menandri incidérint eos at. Mazim ígnota cu mel, elit facilis at nec. Pro ea libris numquám, ñullám veritus accommodaré eú eos.")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")