#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "iframe.*src[^""]+['"]+(https:\/\/www.google.com\/share)"
Local $sString = "<iframe height="100" width="200" src="https://www.youtube.com/share"></iframe>" & @CRLF & _
"" & @CRLF & _
"<iframe height="100" width="200" src="https://www.stackoverflow.com/share"></iframe>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<iframe height="100" width="200" src="https://www.google.com/share"></iframe>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<iframe height="100" width="200" src="https://www.yahoo.com/share"></iframe>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")