re = /iframe.*src[^""]+['"]+(https:\/\/www.google.com\/share)/
str = '<iframe height="100" width="200" src="https://www.youtube.com/share"></iframe>
<iframe height="100" width="200" src="https://www.stackoverflow.com/share"></iframe>
<iframe height="100" width="200" src="https://www.google.com/share"></iframe>
<iframe height="100" width="200" src="https://www.yahoo.com/share"></iframe>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end