package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`iframe.*src[^""]+['"]+(https:\/\/www.google.com\/share)`)
var str = `<iframe height="100" width="200" src="https://www.youtube.com/share"></iframe>
<iframe height="100" width="200" src="https://www.stackoverflow.com/share"></iframe>
<iframe height="100" width="200" src="https://www.google.com/share"></iframe>
<iframe height="100" width="200" src="https://www.yahoo.com/share"></iframe>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}