import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "iframe.*src[^\"\"]+['\"]+(https:\\/\\/www.google.com\\/share)";
final String string = "<iframe height=\"100\" width=\"200\" src=\"https://www.youtube.com/share\"></iframe>\n\n"
+ "<iframe height=\"100\" width=\"200\" src=\"https://www.stackoverflow.com/share\"></iframe>\n\n\n"
+ "<iframe height=\"100\" width=\"200\" src=\"https://www.google.com/share\"></iframe>\n\n\n"
+ "<iframe height=\"100\" width=\"200\" src=\"https://www.yahoo.com/share\"></iframe>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}