using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"iframe.*src[^""]+['""]+(https:\/\/www.google.com\/share)";
string input = @"<iframe height=""100"" width=""200"" src=""https://www.youtube.com/share""></iframe>
<iframe height=""100"" width=""200"" src=""https://www.stackoverflow.com/share""></iframe>
<iframe height=""100"" width=""200"" src=""https://www.google.com/share""></iframe>
<iframe height=""100"" width=""200"" src=""https://www.yahoo.com/share""></iframe>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}