using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)\b(?:V?I{1,3}|I?[VX])\b";
string input = @"Please enter a number between 1 and 10 (inclusive): 8
The Roman number for 8 is VIII.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}