const regex = new RegExp('(?i)\\b(?:V?I{1,3}|I?[VX])\\b', 'gm')
const str = `Please enter a number between 1 and 10 (inclusive): 8
The Roman number for 8 is VIII.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}