import re
regex = re.compile(r"(?i)\b(?:V?I{1,3}|I?[VX])\b", flags=re.MULTILINE)
test_str = ("Please enter a number between 1 and 10 (inclusive): 8\n"
"The Roman number for 8 is VIII.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")