$re = '/(?i)\b(?:V?I{1,3}|I?[VX])\b/m';
$str = 'Please enter a number between 1 and 10 (inclusive): 8
The Roman number for 8 is VIII.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);