re = /(?i)\b(?:V?I{1,3}|I?[VX])\b/m
str = 'Please enter a number between 1 and 10 (inclusive): 8
The Roman number for 8 is VIII.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end