#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<img[^>]+\/?>"
Local $sString = "<a herf="http://www.google.com">test</a></br>" & @CRLF & _
" <p><img src="./../../src/image1.png"/></p>" & @CRLF & _
" <a href="example.mpeg" title="Download movie">film name</a>" & @CRLF & _
" <img border="0" src="/images/image1.jpg" alt="Image" />" & @CRLF & _
" <img border="0" src="/images/image2.jpg" alt="Image"/>" & @CRLF & _
" <img border="0" src="/images/image1.jpg" alt="Image">" & @CRLF & _
"" & @CRLF & _
" <img border="0" src="/images/image3.jpg" />"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")