re = /<img[^>]+\/?>/m
str = '<a herf="http://www.google.com">test</a></br>
<p><img src="./../../src/image1.png"/></p>
<a href="example.mpeg" title="Download movie">film name</a>
<img border="0" src="/images/image1.jpg" alt="Image" />
<img border="0" src="/images/image2.jpg" alt="Image"/>
<img border="0" src="/images/image1.jpg" alt="Image">
<img border="0" src="/images/image3.jpg" />'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end