use strict;
my $str = '<a herf="http://www.google.com">test</a></br>
<p><img src="./../../src/image1.png"/></p>
<a href="example.mpeg" title="Download movie">film name</a>
<img border="0" src="/images/image1.jpg" alt="Image" />
<img border="0" src="/images/image2.jpg" alt="Image"/>
<img border="0" src="/images/image1.jpg" alt="Image">
<img border="0" src="/images/image3.jpg" />';
my $regex = qr/<img[^>]+\/?>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}