import Foundation
let pattern = #"<img[^>]+\/?>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<a herf="http://www.google.com">test</a></br>
<p><img src="./../../src/image1.png"/></p>
<a href="example.mpeg" title="Download movie">film name</a>
<img border="0" src="/images/image1.jpg" alt="Image" />
<img border="0" src="/images/image2.jpg" alt="Image"/>
<img border="0" src="/images/image1.jpg" alt="Image">
<img border="0" src="/images/image3.jpg" />
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)