using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img[^>]+\/?>";
string input = @"<a herf=""http://www.google.com"">test</a></br>
<p><img src=""./../../src/image1.png""/></p>
<a href=""example.mpeg"" title=""Download movie"">film name</a>
<img border=""0"" src=""/images/image1.jpg"" alt=""Image"" />
<img border=""0"" src=""/images/image2.jpg"" alt=""Image""/>
<img border=""0"" src=""/images/image1.jpg"" alt=""Image"">
<img border=""0"" src=""/images/image3.jpg"" />";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}