#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mu)^「(?<busname>[\p{Han}]\d{1,2})\s(?<destination>[\p{Han}]+)行き・(?<boardedat>[\p{Han}]+)」"
Local $sString = "「渋11 渋谷駅行き・駒沢大学駅前」でタッチしました。"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")