re = /^「(?<busname>[\p{Han}]\d{1,2})\s(?<destination>[\p{Han}]+)行き・(?<boardedat>[\p{Han}]+)」/m
str = '「渋11 渋谷駅行き・駒沢大学駅前」でタッチしました。'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end