// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mu)^「(?<busname>[\p{Han}]\d{1,2})\s(?<destination>[\p{Han}]+)行き・(?<boardedat>[\p{Han}]+)」").unwrap();
let string = "「渋11 渋谷駅行き・駒沢大学駅前」でタッチしました。";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}