const regex = /^「(?<busname>[\p{Han}]\d{1,2})\s(?<destination>[\p{Han}]+)行き・(?<boardedat>[\p{Han}]+)」/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^「(?<busname>[\\p{Han}]\\d{1,2})\\s(?<destination>[\\p{Han}]+)行き・(?<boardedat>[\\p{Han}]+)」', 'gmu')
const str = `「渋11 渋谷駅行き・駒沢大学駅前」でタッチしました。`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}