using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<first>.?(\w+|\d+).?),(?P=first)";
string substitution = @"\g<1>";
string input = @"{{1},{1,1}}
{{10},{10,10}}
{{1},{1,2}}
{{1},{1}}
{{a},{a,a}}
{{ab},{ab,ab}}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}