re = /(?P<first>.?(\w+|\d+).?),(?P=first)/m
str = '{{1},{1,1}}
{{10},{10,10}}
{{1},{1,2}}
{{1},{1}}
{{a},{a,a}}
{{ab},{ab,ab}}'
subst = '\\g<1>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result