import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<first>.?(\\w+|\\d+).?),(?P=first)";
final String string = "{{1},{1,1}} \n"
+ "{{10},{10,10}} \n"
+ "{{1},{1,2}} \n"
+ "{{1},{1}}\n"
+ "{{a},{a,a}}\n"
+ "{{ab},{ab,ab}}";
final String subst = "\\g<1>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}