$re = '/(?P<first>.?(\w+|\d+).?),(?P=first)/m';
$str = '{{1},{1,1}}
{{10},{10,10}}
{{1},{1,2}}
{{1},{1}}
{{a},{a,a}}
{{ab},{ab,ab}}';
$subst = "\g<1>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;