import re
regex = re.compile(r"(?P<first>.?(\w+|\d+).?),(?P=first)", flags=re.MULTILINE)
test_str = ("{{1},{1,1}} \n"
"{{10},{10,10}} \n"
"{{1},{1,2}} \n"
"{{1},{1}}\n"
"{{a},{a,a}}\n"
"{{ab},{ab,ab}}")
subst = "\\g<1>"
result = regex.sub(subst, test_str)
if result:
print(result)