using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^COLOR2=\s*(.+)";
string input = @"COLOR1= Light Blue
COLOR2= Dark Red
COLOR3= Pink
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}