re = /(?m)^COLOR2=\s*(.+)/
str = 'COLOR1= Light Blue
COLOR2= Dark Red
COLOR3= Pink
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end