$re = '/(?m)^COLOR2=\s*(.+)/';
$str = 'COLOR1= Light Blue
COLOR2= Dark Red
COLOR3= Pink
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);