package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^COLOR2=\s*(.+)`)
var str = `COLOR1= Light Blue
COLOR2= Dark Red
COLOR3= Pink
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}