import re
regex = re.compile(r"(?m)^COLOR2=\s*(.+)")
test_str = ("COLOR1= Light Blue\n"
"COLOR2= Dark Red\n"
"COLOR3= Pink\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")