#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!(%\\(?:no)?cite\w*\{([^}]*?)\}))[^*\n]*$"
Local $sString = "blablabla" & @CRLF & _
"Author et. al \cite{author92} bla bla. % should match" & @CRLF & _
"\citep{author93} % should match" & @CRLF & _
"\nocite{author94} % should match" & @CRLF & _
"100\%\nocite{author95} % should match" & @CRLF & _
"100\% \nocite{author95} % should match" & @CRLF & _
"%\nocite{author96} % should not match" & @CRLF & _
"\cite{author97, author98, author99} % should match" & @CRLF & _
"\nocite{*} % should not match"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")