import re
regex = re.compile(r"^(?!(%\\(?:no)?cite\w*\{([^}]*?)\}))[^*\n]*$", flags=re.MULTILINE)
test_str = ("blablabla\n"
"Author et. al \\cite{author92} bla bla. % should match\n"
"\\citep{author93} % should match\n"
"\\nocite{author94} % should match\n"
"100\\%\\nocite{author95} % should match\n"
"100\\% \\nocite{author95} % should match\n"
"%\\nocite{author96} % should not match\n"
"\\cite{author97, author98, author99} % should match\n"
"\\nocite{*} % should not match")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")