$re = '/^(?!(%\\\\(?:no)?cite\w*\{([^}]*?)\}))[^*\n]*$/m';
$str = 'blablabla
Author et. al \\cite{author92} bla bla. % should match
\\citep{author93} % should match
\\nocite{author94} % should match
100\\%\\nocite{author95} % should match
100\\% \\nocite{author95} % should match
%\\nocite{author96} % should not match
\\cite{author97, author98, author99} % should match
\\nocite{*} % should not match';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);