package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((([01]?[0-9]|2[0-3]):[0-5][0-9])|sunrise)-((([01]?[0-9]|2[0-3]):[0-5][0-9])|sunset)(,((([01]?[0-9]|2[0-3]):[0-5][0-9])|sunrise)-((([01]?[0-9]|2[0-3]):[0-5][0-9])|sunset))*`)
var str = `00:00-13:59,15:00-23:10,15:00-23:10`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}