import re
regex = re.compile(r"((([01]?[0-9]|2[0-3]):[0-5][0-9])|sunrise)-((([01]?[0-9]|2[0-3]):[0-5][0-9])|sunset)(,((([01]?[0-9]|2[0-3]):[0-5][0-9])|sunrise)-((([01]?[0-9]|2[0-3]):[0-5][0-9])|sunset))*", flags=re.MULTILINE)
test_str = "00:00-13:59,15:00-23:10,15:00-23:10"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)