$re = '/((([01]?[0-9]|2[0-3]):[0-5][0-9])|sunrise)-((([01]?[0-9]|2[0-3]):[0-5][0-9])|sunset)(,((([01]?[0-9]|2[0-3]):[0-5][0-9])|sunrise)-((([01]?[0-9]|2[0-3]):[0-5][0-9])|sunset))*/m';
$str = '00:00-13:59,15:00-23:10,15:00-23:10';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;