import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=(?<http>(?:https?:\\/\\/){1}(?:www\\.)?)?)(?(?=\\k<http>?(?<ipaddr>(?:\\d{1,3}\\.){3}\\d{1,3}(?:\\:\\d{1,5})?))\\k<http>?\\k<ipaddr>(?:\\.[\\w]{1,9})?|\\k<http>(?:[\\w]\\.?){1,255}\\.[\\w]{1,9})(?:\\/.*)?$";
final String string = "https://www.bt.dk/forbrug/salling-group-vil-udnytte-vild-hype-med-populaer-drikkevare\n"
+ "10.135.153.16.dk\n"
+ "https://10.135.154.16.dk\n"
+ "https://10.135.153.16:5000.dk\n"
+ "10.135.153.12:5000.dk\n"
+ "1.1.1.1.dk\n"
+ "1.1.1.1:5000.dk\n"
+ "https10.135.153.16.dk\n"
+ "https://.example.com\n"
+ "https://example\n"
+ "ftp://www.example.com\n"
+ "https://www example.com\n"
+ "htt://www.example.com\n"
+ "https://git.pcsyd.dk\n"
+ "wwwjek.dk\n"
+ "https://100.100.100.100.dk\n"
+ "https://100..100.10.100.dk";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}