import Foundation
let pattern = #"^(?=(?<http>(?:https?:\/\/){1}(?:www\.)?)?)(?(?=\k<http>?(?<ipaddr>(?:\d{1,3}\.){3}\d{1,3}(?:\:\d{1,5})?))\k<http>?\k<ipaddr>(?:\.[\w]{1,9})?|\k<http>(?:[\w]\.?){1,255}\.[\w]{1,9})(?:\/.*)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://www.bt.dk/forbrug/salling-group-vil-udnytte-vild-hype-med-populaer-drikkevare
10.135.153.16.dk
https://10.135.154.16.dk
https://10.135.153.16:5000.dk
10.135.153.12:5000.dk
1.1.1.1.dk
1.1.1.1:5000.dk
https10.135.153.16.dk
https://.example.com
https://example
ftp://www.example.com
https://www example.com
htt://www.example.com
https://git.pcsyd.dk
wwwjek.dk
https://100.100.100.100.dk
https://100..100.10.100.dk
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)