import re
regex = re.compile(r"^(?=(?<http>(?:https?:\/\/){1}(?:www\.)?)?)(?(?=\k<http>?(?<ipaddr>(?:\d{1,3}\.){3}\d{1,3}(?:\:\d{1,5})?))\k<http>?\k<ipaddr>(?:\.[\w]{1,9})?|\k<http>(?:[\w]\.?){1,255}\.[\w]{1,9})(?:\/.*)?$", flags=re.MULTILINE)
test_str = ("https://www.bt.dk/forbrug/salling-group-vil-udnytte-vild-hype-med-populaer-drikkevare\n"
"10.135.153.16.dk\n"
"https://10.135.154.16.dk\n"
"https://10.135.153.16:5000.dk\n"
"10.135.153.12:5000.dk\n"
"1.1.1.1.dk\n"
"1.1.1.1:5000.dk\n"
"https10.135.153.16.dk\n"
"https://.example.com\n"
"https://example\n"
"ftp://www.example.com\n"
"https://www example.com\n"
"htt://www.example.com\n"
"https://git.pcsyd.dk\n"
"wwwjek.dk\n"
"https://100.100.100.100.dk\n"
"https://100..100.10.100.dk")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")