#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\.\w+[\n\W\w]+?(?=^\.\w+|^#>)"
Local $sString = "<#" & @CRLF & _
".SYNOPSIS" & @CRLF & _
"This is the block of code that I would like to have" & @CRLF & _
"matched along with the .SYNOPSIS header, as this block " & @CRLF & _
"belongs to SYNOPSIS" & @CRLF & _
".NOTES" & @CRLF & _
"This block needs to belong with" & @CRLF & _
"NOTES header" & @CRLF & _
".SOMEOTHERHEADER" & @CRLF & _
"And resulting text" & @CRLF & _
"" & @CRLF & _
"#>" & @CRLF & _
"Some other text is in my document but I don't want to ever" & @CRLF & _
"include this section." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")