const regex = new RegExp('^\\.\\w+[\\n\\W\\w]+?(?=^\\.\\w+|^#>)', 'mg')
const str = `<#
.SYNOPSIS
This is the block of code that I would like to have
matched along with the .SYNOPSIS header, as this block
belongs to SYNOPSIS
.NOTES
This block needs to belong with
NOTES header
.SOMEOTHERHEADER
And resulting text
#>
Some other text is in my document but I don't want to ever
include this section.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}