# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\.\w+[\n\W\w]+?(?=^\.\w+|^#>)"
test_str = ("<#\n"
".SYNOPSIS\n"
"This is the block of code that I would like to have\n"
"matched along with the .SYNOPSIS header, as this block \n"
"belongs to SYNOPSIS\n"
".NOTES\n"
"This block needs to belong with\n"
"NOTES header\n"
".SOMEOTHERHEADER\n"
"And resulting text\n\n"
"#>\n"
"Some other text is in my document but I don't want to ever\n"
"include this section.\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.