re = /^\.\w+[\n\W\w]+?(?=^\.\w+|^#>)/m
str = '<#
.SYNOPSIS
This is the block of code that I would like to have
matched along with the .SYNOPSIS header, as this block
belongs to SYNOPSIS
.NOTES
This block needs to belong with
NOTES header
.SOMEOTHERHEADER
And resulting text
#>
Some other text is in my document but I don\'t want to ever
include this section.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end