using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\.\w+[\n\W\w]+?(?=^\.\w+|^#>)";
string input = @"<#
.SYNOPSIS
This is the block of code that I would like to have
matched along with the .SYNOPSIS header, as this block
belongs to SYNOPSIS
.NOTES
This block needs to belong with
NOTES header
.SOMEOTHERHEADER
And resulting text
#>
Some other text is in my document but I don't want to ever
include this section.
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}