$re = '/("[^\s"]+":\s*")\d+(?:\.\w+(?:-\w+)*)+",/m';
$str = '"@material-ui/core": "4.11.4",
"@material-ui/icons": "4.11.2",
"@material-ui/lab": "4.0.0-alpha.58",
"@material-ui/styles": "4.11.4",';
$subst = "$10.0.0\",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;