re = /("[^\s"]+":\s*")\d+(?:\.\w+(?:-\w+)*)+",/m
str = '"@material-ui/core": "4.11.4",
"@material-ui/icons": "4.11.2",
"@material-ui/lab": "4.0.0-alpha.58",
"@material-ui/styles": "4.11.4",'
subst = '$10.0.0",'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result