#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\h+|\h+$|(\R){2,}|(\s){2,}"
Local $sString = " 1 . BritishAirways 15FEB LONDON HONGKONG" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" 2 . CathayPacific 01MAR HONGKONG SHANGHAI" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" 3 . Qantas 12MAR SINGAPORE SYDNEY"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)