re = /^\h+|\h+$|(\R){2,}|(\s){2,}/m
str = ' 1 . BritishAirways 15FEB LONDON HONGKONG
2 . CathayPacific 01MAR HONGKONG SHANGHAI
3 . Qantas 12MAR SINGAPORE SYDNEY'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result