const regex = /^\h+|\h+$|(\R){2,}|(\s){2,}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\h+|\\h+$|(\\R){2,}|(\\s){2,}', 'gm')
const str = ` 1 . BritishAirways 15FEB LONDON HONGKONG
2 . CathayPacific 01MAR HONGKONG SHANGHAI
3 . Qantas 12MAR SINGAPORE SYDNEY`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);