import re
regex = re.compile(r"^\h+|\h+$|(\R){2,}|(\s){2,}", flags=re.MULTILINE)
test_str = (" 1 . BritishAirways 15FEB LONDON HONGKONG\n\n\n"
" 2 . CathayPacific 01MAR HONGKONG SHANGHAI\n\n\n\n"
" 3 . Qantas 12MAR SINGAPORE SYDNEY")
subst = "$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)